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CEPAS 簡易操作マニュアル 

 

はじめに 

このマニュアルは、CEPAS を簡単にお使いいただくために作成いたしました。細かい説

明につきましては、CEPAS ユーザーガイドをご参照ください。 

なお、システム自体もまだ開発途中であり、改良を重ねておりますので、このマニュアル

に表示されているものとは異なる機能が追加されている場合もあります。何かご不明な点

は CEPAS ホームページよりご連絡ください。 

 

（使用にあたっての注意） 

CEPAS システムを使用する際には 1600×900 ピクセル以上のパソコンが必要になりま

す。このサイズより小さいパソコンでは、システムを表示できないのでご注意ください。 

 

 

A. Animate Map の見方 

 

◇A-1. システムの起動 

デスクトップより、CEPAS システムを選択します。下のような画面が表示されます。 

 

Fig1.CEPAS メイン画面 
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◇A-2.  Mesh File の設定 

画面が立ちあがったら Setup→Mesh→Mesh Files の中から今回解析したい Mesh File の

種類を選びます。 

(Mesh File を選ぶときは、配列とエクストラ電極の有無に応じて選択してください。) 

 

 

Fig2. Mesh File の選択 

 

  

Fig3.ダイアログボックス 

Mesh File の設定が完了したら、最初の画面

右上のFile→Openを選択するとFig3.のよう

なダイアログボックスが表示されます。 

使用するシステムに応じて選択し、‘LOAD’

ボタンを押します。 

 

選択する Mesh File に

よって、Map Display

の電極配列が変わりま



3 
 

次に図(Fig.4)のように分析したいファイルのデータを選択します。ファイルの形式は

Excel File で.csv 形式になっている事を確認して下さい。(NavX Classic のデータ

は.csv 形式で保存されます。) 

※表示されない場合は一番下の‘Save as type’を All File にしてください。 

 

Fig4. データの選択 

 

データを表示させると、Fig.5 のような画面が表示されます。これは、データの分布を視

覚的に確認するためのもので、分析には直接関係はありません。この画面から、カテの不

具合や接触不良によるデータエラーの電極情報を視覚的に見つける事ができます。 

 

Fig5.3D 電極分布図 
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Fig6.Uni polar Spline Labels 

 

 

 

 

 
Fig7.Bipolar Spline  

 

 

（Unipolar の場合） 

(例)BKA D→Basket カテーテル、Spline A のディスタール電極。 

三次元画像上の紫の点が電極の位置です。(Fig.5   ) 

 

BKA 2→Basket カテーテル、Spline A 上の 2 番目の電極。 

三次元画像上の青の点が電極の位置です。 

 

※3 次元画像上に表示された点の位置がおかしい、点が無い場合は 

記録されているデータに何らかのエラーがあると思われます。 

この場合は、元の excel データを確認する必要があります。 

(Bipolar の場合) 

(例)BKA D-2→Basket カテーテル、Spline A のディスタール、

２番電極間。 

3 次元画像上の紫の点が電極間の位置になっています。 
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Fig8.電極位置の確認ボタン 

 

 

 

Fig9.フィルターの設定 

 

① Extra channel 

Basket カテーテル以外のカテーテル電位(CS など)

を含む時には電極数に応じて数を調整します。 

(調整を行わないと、3D グラフで電極の位置を確認

した際、ずれて表示されてしまいます。) 

 

 Spline Index 

BasketカテーテルのSplineを選択することができ

ます。 

 

 Data Segment Length(sec) 

データが何秒間記録されているか確認できます。 

 

④ Spline Labels 

電極の位置を色によって確認できます。 

 

このデータで OK ならば、Continue ボタンを押す

 
① ② 

③ 

④ 
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◇A-3. フィルターの設定 

解析をしやすくするために、フィルターの設定をして f 波ができるだけノイズの少ない状

態になるように設定していきます。 

 

Fig10.フィルター設定画面  

 

 

Filter All Channel…バスケットカテ上の 64 極全てに反映されます。フィルターがかか

っている状態だと Fig.11  部分の文字が黒から青に変わります。 

 

 

Fig11.フィルター設定後の画面 
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Fig12.フィルター設定ボタン 

 

Filter Display Channels…画面上に表示されている波形にのみフィルターがかかります。

Filter Display Channels 内にある One ch only は、選択した画面上の波形 1 つにのみフィ

ルターがかかります。All in display は、画面上の波形全てにフィルターがかかります。 

Notch Filter…電源回路のノイズを取り除きます。 

Low Pass…高周波数ノイズを取り除きます。 

High Pass…低周波数ノイズを取り除きます。 

Baseline…波打っている波形をフラットな状態に調整できます。 

 

ノイズの除去に関しては、波形の状態を見つつフィルターを調整してください。 

 

※フィルターをかけても、時間軸の位置をずらすとリセットされてしまいます。 

 

※また、自分がどのフィルターを選択したのか覚えておく必要があります。 

フィルターをかけて Detect 作業を進めるのですが、一度 CEPAS を終了させてしまうとフ

ィルターのセッティングもリセットされてしまいます。Animate Map を適切に表示させる

為に再び同じフィルターセッティングを行った後に再生させる必要があります。 
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◇A-4. 波形の切り出し 

フィルターの調整が終わったら、解析したい波形の切り出しをします。1sec, 2sec で記録さ

れたものはそのまま解析する事も可能ですが、長時間電位を記録した場合、2sec～4sec に

波形を切り出して解析することをお勧めします。 

 

 

Fig13.波形の切り出し 

 

Fig.13①欄から切り取りたい時間を選択します。 

(Ex 4sec の場合は 4sec のボタンを選択します。) 

 

Fig.13 の②から、時間軸を選択します。マウスで時間軸を移動させる事ができますが、 

右上のボタン     を選択すると、4sec ごとに時間軸が切り替わります。 

 

8ec のデータを解析するときは、最初に 0 sec ～4 sec で detect を行い、データを保存した

後、次の 4 sec ～8 sec のデータの detect を行います。 

Detect を行った際の編集時間(例えば 4sec で detect を行ったとしたら)Animate Map で再

生できるのも 4sec のみになります。 

連続で 8sec 再生させたい場合は、直接 8sec の編集しなければなりません。 

 

 

 

 

① 

① 
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◇A-5. キャリパーの使い方 

R-R 間隔など波形上の計測を行いたい際、キャリパーを使用します。 

波形上にある小さな○と×のマークがキャリパーになります。 

計測したい波形の上で右クリックを押すと Fig14 で表示されているようなダイアログボッ

クスが表示されます。 

 

Fig14.キャリパーの使用 

 

次に Caliper Cursor Move を選択します。このキャリパーは○が始点、×が終点となって

います。 

カーソルごと動かしたい時には、together を選択し○の部分を左クリックしながら移動さ

せます。測定距離を変えたいときは、individual を選択し、×の部分をクリックしながら移

動させます。このキャリパーは波形上に常に表示されているので、もしキャリパーが見つ

からない場合は波形上で右クリック、Calipers Find を選択すると現れます。 

計測した数字が見えにくい場合は、数字の位置をずらす事もできます。 

 

また、Fig.14 上のダイアログボックス上にある Copy Data を選択すると、波形の画像のみ

がコピーされ、その画像を貼り付ける事が可能です。 
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Fig15.キャリパーを使用しての計測 

 

 

◇A-6.切り取った波形の保存 

波形の切り取りが完了したら、その波形を一度保存します。 

画面左上の File から Export→Display View to CEPAS format を選択し、OK ボタンを押

します。 

ここでは、切り取った波形情報を.dat ファイルで保存します。 

ファイル名をつけて OK ボタンを押すと、.dat ファイルが作られるのと同時に.h ファイル

も作られます。これらのファイルは両者がそろって初めて機能するものなので、.h ファイ

ルが同時に作成されているか確認してください。 

 
Fig16.ファイルの選択 
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◇A-7. 解析画面の立ち上げ 

 

解析画面は、CEPAS のフィールドで行うので、File→CEPAS を選択します。 

 

 

Fig17.ダイアログボックス 

 

 

 

保存した波形ファイルを選択します。この時のファイル形式は.dat である事を確認してく

ださい。 

 

 

Fig18. dat ファイルの選択 

 

 

 

 



12 
 

このような画面が表示されます。この時に    (Title Data Graph)の時間軸が 4sec に

なっている事を確認してください。 

 

Fig19.波形の読み込み後 

 

◇A-8. 波形の Detect を行う 

F2 キーを押すと、Fig.20 のような画面が表示されます。 

※Velocity データに関する Detect の方法は最後の章を参照してください。 

 

(V マーカーの付け方) 

V マーカーとは? 

最初に、R 波にマーカーをつけることで、他の電極の R 波も見分けやすくする事ができま

す。1 つのテストチャンネルに V マーカーをつけると、全ての電極に反映されます。 

 

Fig20.detect 編集画面 
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①最初に R 波を見つけやすい波形選択します。 

 

Fig 21.V マーカーの使用方法 

 

②ポイントを拾うための Feature Type を R 波に応じて選択します。今表示されてる波形の

R 波を拾うために Minimum を選択します。(V が上向きの際は Maximum を選択します。) 

③Snap to Feature と SHIFT を選択して、V のみを拾って行き、一番下の段にある New V 

Markers を選択します。 

 

 

Fig22.V マーカー選択ボタン 

 

④画面のように R 波の範囲をカバーするように緑の帯が現れます。 

この緑の帯の範囲は V width で変更する事ができます。 
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Fig23.R 波の選択 

 

⑤最後に Remove All Detections を選択して R 波のポイントを消去します。 

※このポイントを残してしまうと、Animate Map 再生の際に反映され正しい画像が得られ

なくなってしまうので、最後にかならずポイントの消去を行ってください。 

 

マーカーを消去したい場合には Remove V Markers を選択します。 

一度消去した V マーカーを再び表示させたいときには Recall V Markers を選択します。 

 

(Detect の方法) 

 

Fig 24.Detect 編集画面 
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※フィルターの値が 0-25Hz の時は、フィルターが強くかかっている状態なので Onset 

(Minimum Value)に合わせて detect をおこなっていきますが、0.1-300Hz のフィルター設

定では、Raw data に近いシャープな波形が得られるので、波形の立下りの部分(Minimum 

slope)に合わせて Detect を行っていきます。 

 

 
Fig25.Detect 編集ボタン 

 

(機能の紹介) 

Swap…Adjacent Channel Electrogram とTest Channel Electrogramの波形を入れ替える

事ができます。 

Snap to Feature…Feature type を選択して SHIFT ボタンを選択すると detect 作業を行っ

ていく際、自動的にポイントの微調整をしてくれる。SHIFT ボタンを off にすると手動で

選んだポイントの微調整ができます。 

DELETE…DELETE ボタンが on の間、Test Channel Electrogram 上のポイントを削除す

る事ができます。(この DELETE ボタンは、キーボード上の Delete キートは異なります。) 

DELETE ボタンとその隣にある Hold マークをクリックすると、連続的にポイントの削除

が行えます。 

 

Autoscale X…この機能に関しては、ユーザーマニュアルを参照してください。 

 

ポイントの位置を修正したい場合、   マークをクリックすると、左右に微調整ができ

ます。また、Remove All Detections のボタンを選択すると、画面上の全てのポイントが削

除されます。 
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※この Detect 作業は、NavX Classic データ Unipolar で 56 電極分、Bipolar で 48 電極分

行う必要があります。(トータルの電極数は unipolar64 極、bipolar で 56 極ですが、解析の

際には proximal の電極データを除いているので、この数になります。)また、この作業は

Animate Map の再生に大きく関わってくるので、丁寧に行う必要があります。 

 

Fig26.Detect 編集画面 

 

Adjacent Channel ･･･Test Channel Electrogram での detect が困難な場合に参考となる

波形を表示しています。 

Test Channel Electrogram･･･実際に detect を行う波形を表示しています。(実際の編集に

使うのは、このグラフのみで、他２つのグラフは参考のためのものとなっています。) 

Beat to Beat Intervals…Detect を行った波形の間隔を表示しています。 

 

Fig.26①Test Channel Electrogram の前 or 後の波形を表示させる事ができます。 

②の欄の Previous にチェックが入っている場合は、Test Channel Electrogram の 1 つ前の

電極波形、Next にチェックが入っている場合は Test Channel Electrogram の１つ後の電

極波形が Adjacent Channel に表示されます。 

Adjacent Channel は Test Channel Electrogam と連動して表示されます。チェックが入っ

ていない場合は、固定されたまま変化しません。 

③編集したい波形を表示させる事ができます。上下の矢印で、Channel Index の数を変え

られますが、キーボードでの直接入力も可能です 

※Channel Index はコンピューターに認識させるための数なので、バスケットの数字とは

関係ありません。 

④の Export Detection で、Detect 途中の波形を保存できます。 

① 

② 

④ 

③ 

※Detect を行う際は、まめにセーブする事をお勧めします。誤って Detect 編集画面を閉じ

てしまうと、それまでの作業がすべて失われてしまいます。 
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◇A-8. 途中で作業を中断する場合 

(Export Detections)ボタンを押すと、保存先の表示画面が出てきます。 

保存時は、テキストファイル形式で保存されます。ファイルに名前をつけて OK ボタンを

押すと、保存完了となります。その後は Exit または Ctl+q から、終了してください。 

 

 

◇A-9. 中断した作業を再開する場合 

File→Open→CEPAS を選択し、Load ボタンを押す。 

この時は、CEPAS のフィールドで作業を再開させる必要があるので、保存してある.dat フ

ァイルを最初に開きます。 

 

 

Fig27.編集途中ファイルの選択 
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Fig28.フォーマットパラメーターBox 

 

 

Fig29.Detect ファイルの読み込み 

 

次に Detect 途中のファイルを開くため、File→Import→ Detection File を選択し、保存し

たテキストファイルを選択します。F2 キーまたは Shift キーを押しながら左クリックをす

ると、再び Detect 作業を再開する事ができます。 

 

OK ボタンを押します。 

 

 

※作業を再開する場合や、一度 CEPAS を終了させて再開する時には、必ずフィルターをセ 

ッティングし直してください。一度画面を閉じると、フィルター機能はリセットされます。 
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◇A-10. Animate Map から Rotor の動きを確認する。 

Detect が完了したら、Exit(Esc)を押します。 

次に、Fig.29 上の Other を選択して Animate Map のセッティングを行います。 

 

 

Fig.29 参照  

Frame Step(ms)…何 msec 毎にフレームが動くか設定できます。 

Frames…動くフレームの細かさを設定できます。(長く設定しすぎると Animate Map がゆ

っくり再生されます。途中で stop させる事も可能です。) 

Phase Template…この機能につきましては、ユーザーガイドを参照して下さい。 

Width…この機能につきましては、ユーザーガイドを参照してください。 

 

 

Fig30.Animate Map の再生 

 

（ex : Frames の数を増やし、Frame step 数を上げれば細かく滑らかな画像が得られます。） 

また、Animate Map の再生時間は Frame Step 数×Frames 数で得られます。 

(ex : Frame Step 数 20ms, Frame 数 100 の場合、再生時間は 2 秒間という計算になりま

す。) 

 

※Frame Processing Allowance(ms) に関してコンピューターの計算時間に関するものな

ので、設定は変更する必要はありません。 

 

設定が完了したら、Animate Map の再生ボタンを押すと、Rotor の動きを反映した動画を

見る事ができます。 
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B. Isochronal Map の見方 

 

今回のこの簡易マニュアルでは、操作の手順をできるだけ分かりやすく説明するために、

例としてサイナスの波形を使用しています。 

 

◇B-1. Mesh File の設定 

最初に、12 誘導での画面表示に切り替えるために Mesh File の設定を行います。 

Setup→Mesh→Mesh Files→Constellation (今回は例として Boston カテを使用しているの

で、Constellation という名前がついていますが使うデバイスによってこのファイルの名前

も変わります。)の中から、今回の解析に合ったファイルを選択します。 

 

Fig31.CEPS メイン画面 

 

 

Fig 32. Mesh File の中身 
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◇B-2. データ解析 

 

Fig 33.CEPAS ダイアログボックス 

 

 

Fig34.ファイル選択画面 

 

 

 

① File→OpenからBard ASCIIを選択

し Load ボタンを押します。 

②今回解析する波形のファイル(.txt 形式のも

の)を選択し、Load を押すと、Fig.27 のよう

な画面が表示されます。(Bard フォーマット

はテキストファイルで保存されます。) 
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Fig30.波形読み込み後の画面 

 

 

 

Fig31.波形の切り出し 

①  
①  

まず、①より、時間軸を選択します。 

Isochronal Map の場合、8 秒間では画面上

に f 波が多く表示されるので異なったアク

チベーションタイムが見られますが、短い

時間(1sec～2sec)で波形の切り出しを行う

方が波形の編集をしやすくなります。 

 

②を Basic  Activation に設定します。 
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次に、Fig.32    の Feature Type の設定を Positive Peak に設定します。 

Max Type を First Found に設定します。(今回はサイナスデータを用いた例なので、症例に

応じて異なる設定も可能です。) 

 

 

Fig32.設定画面 

 

 

 

Fig33.Threshold の設定画面 

③Threshold の設定。 

Threshold は、波形のピークを検知するために設定

される値で、Fig.33 の波形の赤いラインがそれに値

します。 

Threshold の設定は、波形を見つつ適宜調整してい

きます。 

※入力された Threshold の値は、CALCULATE 

(or F9)ボタンを押さないと反映されません。 
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◇B-3. Isochronal Map の表示 

CEPAS では Isochronal Map を見る際、電極配列は Dr.Narayan の説に従って配列してありま

す。 

 

Fig.34 Dr.Narayan の学会文書より引用 

 

Fig.35 Dr.Narayan の学会文書より引用 サイナスの IsochronalMap 
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Fig.36 左房の Isochronal Map  

 

 

Spline E,D が Mitral に一番近い Spline となっています。 

A 

B 

C 

E 

D 

F 

G 

H 

D-2 7-6 7-8 ・・・ 

S
p
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e 

電極 
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Fig37.左房のモデル図 

 

設定が全て完了したら、CALCULATE ボタンを押します。CALCULATE ボタンを押すと、Fig38

のような Map が表示されます。 

 

Fig38.Isochronal Map 

ちょうど、点線の 

あたりでカットして、上下に

開いたようなイメージになり

ます。 
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◇B-4. Reference カーソルの設定。 

最早期が赤、最も遅い部位が紫で表示されます。Fig.39(上)のような Map では、最早期が

分かりにくいので、Reference ラインを調整する事で、Map 画像の修正を行っていきます。 

 

 

Fig39.Isochronal Map 編集画面   

Reference ラインの位置が、波形よりも遅れた位置に調整されると、Isochronal Map は黒

く塗りつぶされて表示されます。この場合、Reference ラインの調整をする必要があります。 

Reference のライン

を右にシフトさせ
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Fig40.Isochronal Map の編集 

 

B-5. Isochronal Map の修正の仕方 

 

5-1.表示された Isochronal Map を修正する場合、まず、Referenceline の位置を決めます。 

波形が全体的に青い場合は、Reference ラインを右にずらします。全体的に赤い場合は左に

ずらし、CALCULATE を押します。 

5-2.次に Map 上のポイントを選び左クリックします。 

5-3.修正したい部分の波形が表示されます。 

5-4.バーの位置を調整します。この時のバー(チャンネルカーソル)の位置はポジティブピ

ークで合わせて下さい。 

波形の形が正しく認識できないようであれば、波形上で右クリックを押して Activation 

Reject を選択すると、Isochronal Map 上の領域が空白になります。Fig41 参照。 

 

Isochronal Map 上で空白の部分を満たしたい場合は、同じく Map 状の点の上で右クリック

し、波形を表示させ、Activation Select を選択すると、(チャンネルカーソルバー)が出て

くるのと同時に Map 上の空白になっている領域も満たすことができます。 

 

Fig40.の    より、Reference line よりもバーの位置が後ろに来ていると Low colour

として黒に色分けされます。 

また、Reference line よりバーの位置が 100msec(この数は MaxMap Value にて変更可能)よ

り前にあると High colour としてグレーに色分けされます。色は自由に帰る事ができます。 
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Fig41.Isochronal Map の調整 

 

 

 

 

 

 

          

 

①白い点の領域を修

正したいので、ここで

右クリック 

②白い点の波形が白

線形で表示されま

す。 

③バーの位置をずらす、また

は Activation Reject を選択。 

修正前の Map 

バーの位置が適切でないため修正が必要です。 

Animate Map 上で白い点を選択し、白い波形上で Activation Reject 

を選択。白い点の周辺のジオメトリーは空白に表示されます。 

修正後の Map 

バーの位置をマニュアルで適切な位置に移動させます。 
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Velocity の Animate Map の表示 

 

Velocity バージョンを使用するにあたって 

Velocity のデータを解析するにあたって、NavX バージョンの解析方法と比較すると、使用

するファイル形式、Detect の方法が NavX と比較すると若干異なりますた基本的な操作方

法は NavX Classic バージョンとほとんど変わりありません。 

 

 

1. 使用できるファイル形式について 

Velocity で記録されたデータは、一度 CEPAS 上で使えるようにファイル形式を変える必要

があります。(この工程に関しては Dr.Madry に依頼する必要があります。) 

(CEPAS 上で使えるファイル形式は.dat(.h)ファイルになります。) 

 

データを開く際は、Open→CEPAS を選び、その中から.dat ファイルを選択します。 

 

 

2. 電極の情報を視覚的に判断できる 3D グラフの表示(NavX Classisc の際に表示され

ていたもの)が Velocity のデータでは見る事ができません。 

 

 

図 1. 3D 電極分布図 

 

 

 

 

表示ができなくなる 
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3. Velocity data の Detect 方法 

 

Velocity で Detect を行う際は、10sec 毎の編集を計 3 回行って行くか、NavX Classic と同

様に、4sec 毎に編集を行っていく方法をお勧めします。4sec 毎の Detect の編集方法は、

NavX Classic のものと同様になるので、そちらを参照してください。 

 

 

(10sec x 3 で Detect する方法) 

 

Detect の作業自体は解説書に表記してある方法と変わりありません。 

まず時間軸の設定を 10sec にするため Max を選びます。 

 

図 2. 時間軸の調整の仕方 

 

※すでにデータは(.dat & .h ファイル)が作られているので、ここでは NavX バージョンの

解説書で示した.dat / .h ファイルを作る必要はありません。 

 

F2 を選択して Detect 作業を進めていきます。 

この時表示される波形は 2sec となっています。(Time(sec)の max の値を変えると最大で表

示される波形の時間が変わります) 



32 
 

ｆ波のポイントが選択しやすい波形の時間幅を選択してください。 

図 3○の値を 10 から 4 に変えると図 4 のような波形に変わり、編集しやすくなります。 

 

図 3. Detect 編集画面(10sec) 

 

 

 

図 4. Detect 編集画面(4sec) 

 

図 4 の波形が得られたら、必要に応じて V マーカーを用い Detect を行って行きます。 

図 4 で表示された波形は 10sec の波形の中の最初の 0～4sec が表示されている状態になっ

ています。
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図 5.最初の 0～4sec の Detect 完了 

 

表示されている 0～4secDetect 作業が終わったら、画面上の  

を選択し、表示させていた波形の位置を左にシフトさせ、引き続き Detect を行って行きま

す。 

 

 

図 6.Detect 編集画面 

波形を左に 

ずらす。 
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波形をずらしながら編集し、10sec 分の作業が終了したらセーブします。 

 

図 7.Detect 作業 10sec までの編集 

 

※10sec 毎で Detect を行っていただいた際は、再生できる Animate Map の再生時間も

10sec 毎になります。もし、従来の方法で 4sec 毎に Detect を編集していただいた際は、

Animate Map の再生時間は 4sec 毎になります。 


